From Gentoo Wiki
Jump to:navigation Jump to:search
Before creating a discussion or leaving a comment, please read about using talk pages. In particular, sign comments using ~~~~ and add new discussions at the bottom of the page. New discussions should be made visible with {{Talk|date = 2024-05-23}}.
== Discussion title ==

{{Talk|date = 2024-05-13}}

A comment [[User:Larry|Larry]] 13:52, 13 May 2024 (UTC)
: A reply [[User:Sally|Sally]] 11:29, 14 May 2024 (UTC)
:: Another reply [[User:Larry|Larry]] 21:41, 23 May 2024 (UTC)
:: Your reply ~~~~

Navigate to first:

 Probably ready for translation


this page seems mature to me, could we mark changes for translation please ? Will do it in french, will allows other countries to do it, as well :). This software is popular and would be neat to translate it.

Regards, Kévin GASPARD DE RENEFORT (talk) 09:25, 23 April 2024 (UTC)

GLIBCXX_3.4.15 not found

Talk status
This discussion is done.

I ran into this error:

   /home/user/.local/share/Steam/ubuntu12_32/ /lib32/ version `GLIBCXX_3.4.15' not found (required by /home/user/.local/share/Steam/ubuntu12_32/

The solution was to check /lib32/ which was still symlinked to the previous gcc version.

— The preceding unsigned comment was added by VStone (talkcontribs) 11 December 2012


Talk status
This discussion is done.

Since when is pulseaudio a dependency? I don't have it and you can set ALSA in steam anyway.

-- Hasufell 14:48, 8 November 2012 (UTC)

above comment for amd64

-- Hasufell 20:23, 9 November 2012 (UTC)

On amd64, I don't use NetworkManager and the Steam client works fine. I haven't tried to play any online games though. I advocate for removing these two (or categorizing them as optional if there is justification):
  • media-sound/pulseaudio
  • net-misc/networkmanager
-- Jwmurphy (talk) 01:57, 20 October 2013 (UTC)

Can we remove the whole dependencies sections? I just installed steam using the manual method without installing any kind of dependency upfront. Also tried 1 game (Transistor) and that worked perfectly fine. Since Steam is already using steam-runtime (I get this when starting steam: STEAM_RUNTIME has been set by the user to: /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime) I think we can expect steam to supply it's own deps.

The current list of x86_32 packages I have is:

$ eix -c --installed-with-use abi_x86_32
[I] dev-libs/libpthread-stubs (0.3-r1{tbz2}@10/21/2015): Pthread functions stubs for platforms missing them
[I] x11-libs/libX11 (1.6.2{tbz2}@10/21/2015): X.Org X11 library
[I] x11-libs/libXau (1.0.8{tbz2}@10/21/2015): X.Org X authorization library
[I] x11-libs/libXdmcp (1.1.1-r1{tbz2}@10/21/2015): X.Org X Display Manager Control Protocol library
[I] x11-libs/libXext (1.3.3{tbz2}@10/21/2015): X.Org Xext library
[I] x11-libs/libxcb (1.11-r1{tbz2}@10/21/2015): X C-language Bindings library
[I] x11-proto/inputproto (2.3.1{tbz2}@10/21/2015): X.Org Input protocol headers
[I] x11-proto/kbproto (1.0.6-r1{tbz2}@10/21/2015): X.Org KB protocol headers
[I] x11-proto/xcb-proto (1.11{tbz2}@10/21/2015): X C-language Bindings protocol headers
[I] x11-proto/xextproto (7.3.0{tbz2}@10/21/2015): X.Org XExt protocol headers
[I] x11-proto/xf86bigfontproto (1.2.0-r1{tbz2}@10/21/2015): X.Org XF86BigFont protocol headers
[I] x11-proto/xproto (7.0.27{tbz2}@10/21/2015): X.Org xproto protocol headers

Simonvanderveldt (talk) 12:56, 22 October 2015 (UTC)

I doubt it. I think some of the package dependencies are automatically pulled in now, but don't forget on 64bit platforms, the many packages require 32 bit builds. Especially media-libs/libsdl2 32bit, as libsdl2 is required for many games. So although a few packages are required for Steam, there are a lot more dependencies not directly required by Steam, but are required for games! (ie. libsdl2) Without those additional dependencies, binary games or applications tend to segfault with little to no explanation, or even a clue there are any missing libraries. I know. Another wonderful fine mess we're in! However, this is just my two sense and brief experience using Steam with ARMA 3. You might be more correct than I, but dunno. --Roger (talk) 02:41, 23 October 2015 (UTC)
Roger, thanks for the input. As far as I know SDL/libsdl2 should be part of steam-runtime, which basically packages all files a game can depend on, see
If a game doesn't work that would indicate a packaging/building issues with that specific game. Maybe they used a lib that isn't in steam-runtime but forgot to supply it themselves.
In regards to the issues you had with ARMA3, this seems to fix it which is basically adding the so from steam-runtime to LD_PRELOAD. Maybe you can try if that works? I don't have ARMA3 so can't try it unfortunately.
Update: Just tried The Witcher 2 and XCOM: Enemy Unknown and both work without issues as well.
What I do get in the terminal is
ERROR: object '/home/simon/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/simon/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
This repeats a couple of times and it differs per game if I see the only the ubuntu12_32 path or also the ubuntu12_64 path. Despite these messages the games still run fine and the Steam overlay works fine as well. Simonvanderveldt (talk) 16:11, 23 October 2015 (UTC)
Ditto with the above error. Do you have libsdl2 (32 bit) installed? If so, steam/arma is just likely falling back to the system libsdl2. I'm apparently running fine using my (Gentoo) system installed libsdl2 (32 bit, 64 bit) builds. --Roger (talk) 03:22, 24 October 2015 (UTC)
I don't have libsdl2 installed at all (neither 64 or 32 bit). It's being used from the steam-runtime.
To get to the bottom of this I did some digging through the ~/.local/share/Steam/ shell script that is used to launch Steam. If you search for LD_LIBRARY_PATH you'll find that from line 702 onward multiple locations from the steam-runtime are being added to LD_LIBRARY_PATH as well as the files present in $STEAMROOT which is the directory ~/.local/share/Steam/ubuntu12_32. This last directory contains for example.
Finally if the env var $STEAMOS is null (see line 716) there is a check on line 419 (function check_shared_libraries()) if there are unresolved dependencies for ~/.local/share/Steam/ubuntu12_32/ using ldd, this is the output from that ldd command: => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf63f4000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf63a8000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf5abd000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf56c3000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf55bd000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf55b6000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf55af000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf55a6000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf5594000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf5460000) => /usr/lib32/ (0xf535c000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf530c000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf5213000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf4daa000) => /lib32/ (0xf4d87000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf4d39000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf4cfc000) => /lib32/ (0xf4cb6000) => /lib32/ (0xf4cb1000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf4bc8000) => /lib32/ (0xf4bae000)
/lib/ (0xf77d2000) => /lib32/ (0xf4a10000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf47f5000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf3c7b000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf3c60000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf38d1000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf388d000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf386c000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf383f000) => /home/simon/.local/share/Steam/ubuntu12_32/ (0xf37ea000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf37df000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf37bd000) => /usr/lib32/ (0xf37b8000) => /usr/lib32/ (0xf15e9000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf15e1000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf15a5000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf14f6000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf14e9000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf14c9000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf13fc000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf12a4000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1278000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf122e000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf11f9000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf11f0000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf118b000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf1141000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf113c000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf1111000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf10ae000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1057000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1053000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf104b000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1047000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1036000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf102b000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1026000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf1022000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0f87000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0eec000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0ee7000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0edd000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf0ec7000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf0ea8000) => /lib32/ (0xf0e91000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf0e66000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ (0xf0e5c000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0dea000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0de3000) => /lib32/ (0xf0dc9000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0d7b000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0c03000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0bd8000) => /home/simon/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (0xf0bcf000)
The only hint in about system libs is the lines 709 and 710, which contain
# Need to add /usr/lib32 to the library path to pick up on Ubuntu 12.04
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH-}:/usr/lib32"
Simonvanderveldt (talk) 08:57, 24 October 2015 (UTC)
Is it me, or does it seem the script file is sparsely commented, and the comments do not state specifically what each statements intended purpose? I looked over the script file, and the comments made the statements appear the statements were not performing much of anything at all! (If anybody looks at my scripts, even a beginner can figure out what my scripted statements do. ;-) I'll try to remember to document the ARMA 3 gentoo wiki, and notes should likely be made to the Steam article somehow? --Roger (talk) 15:30, 24 October 2015 (UTC)

I wonder about the libpng:1.2 in the @steam set. While running glsa-check I noticed that libpng:1.2 had two active GLSAs (GLSA-201010-01 & GLSA-201206-15). While digging I found that is already included in the Steam runtime. Is there any reason to install this lib system-wide in this case? I'm probably missing something but the majority of users won't disable STEAM_RUNTIME, right? Shouldn't the Wiki conform to this and just add a warning about dependencies to users that want to disable the runtime for whatever reason? Fcl (talk) 21:57, 1 May 2016 (UTC)

The current dependency list is problematic since it's trying to serve two purposes. First, as a dependency list for manual installs, and second, as a dependency list for users who disable the Steam runtime. There is currently a note about the list being outdated and that some dependencies might not be used if the Steam runtime is enabled. This note should be clarified, but what we really need is two separate dependency lists.--BT (talk) 01:32, 2 May 2016 (UTC)

Below is a list of shared objects required by ~/.local/share/Steam/ubuntu12_32/ with the Steam runtime enabled, on my amd64 system using a multilib profile and Intel graphics. I did a manual install of Steam, and have no 32-bit packages/libraries installed except for those that are installed by the profile (i.e. 32-bit glibc):

user $$ lddtree ~/.local/share/Steam/ubuntu12_32/ => ~/.local/share/Steam/ubuntu12_32/ (interpreter => none) => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => /lib32/ => not found => not found => /lib32/ => /lib32/ => /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/ => /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/ => /lib32/ => /lib64/ => /lib32/

It would be great if someone else can confirm this. The dependency list should be for the Steam client, and not the dependencies required by games. That should be handled separately in Steam/Games troubleshooting.--BT (talk) 03:46, 2 May 2016 (UTC)

In order to satisfy the requirement on from the above list, I started by adding only media-libs/mesa abi_x86_32 to package.use. Portage then listed all the further packages that would be need have abi_x86_32 set. I realized from that list that it may be impossible to have a definitive list of dependencies. There are just too many variables. For example I use Plasma 5, which requires that media-libs/mesa be built with the wayland USE flag. So building a 32-bit Mesa requires a 32-bit Wayland, even though Steam doesn't use it at all. So having a dependency list that includes Wayland is silly. There are other dependencies that would also vary from system to system, e.g. udev or eudev. I think it may be best to instruct the user to just add media-libs/mesa and maybe a couple other dependencies that aren't pulled in by media-libs/mesa, and let Portage instruct the user which additional 32-bit packages are needed. This is similar to how the steam-launcher ebuild handles dependencies. Any thoughts?--BT (talk) 06:12, 2 May 2016 (UTC)

Segmentation fault 64bit (might be 32bit aswell) due to wrong locale

Talk status
This discussion is still ongoing.

Trying to figure out why steam wouldn't launch in 64bit mode for days resulted in finding out it may be a locale issue. Launching steam with LC_ALL=C made it work just fine. Haven't tested it on gentoo 32bit, as I don't have that around anymore. -- oliver 09:20, 14 June 2014 (UTC)

cannot connect to X window server in 32bit chroot

Talk status
This discussion is done.
$ emerge x11-apps/xhost
$ xhost local:${your_username}

# get into chroot
$ /path/to/

Probably need x11-apps/xhost to make it work. AleiPhoenix (talk) 08:24, 14 July 2014 (UTC)

xhost is now included in the chroot instructions. --BT (talk) 00:04, 17 January 2019 (UTC)

Games troubleshooting

Sid Meier's Civilization V

Talk status
This discussion is done.

In the newest update of the Steam, the error

ERROR: object ' $HOME/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

appears and the game does not start. Adding


to the launch options solves the problem [1], at least for my hardware configuration

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R7 370 / R9 270X/370 OEM 

(radeonsi driver), so the issue does not concern only Intel GPUs.--Nezumi8407 (talk) 19:10, 31 January 2016 (UTC)

Did you get a GLXBadFBConfig error in tmp/gameoverlayrenderer.log as per
Simonvanderveldt (talk) 21:05, 31 January 2016 (UTC)
No, since there is no /tmp/gameoverlayrenderer.log. How can I get it? --Nezumi8407 (talk) 20:34, 1 February 2016 (UTC)
OK, the reason, why I had to use aforementioned setting was, that my media-libs/mesa was compiled with bindist use flag enabled, so I had only OpenGL 2.0 available. I disabled the use flag and compiled mesa with llvm-3.7.1 and now I don't have to specify any variable for the game. --Nezumi8407 (talk) 18:27, 2 February 2016 (UTC)
Thanks for getting back on this! Always nice to have the actual cause + solution :) Simonvanderveldt (talk) 19:42, 4 February 2016 (UTC)

Should we think about splitting the page up?

Talk status
This discussion is done.

The page is starting to get rather long, covering both client and specific game issues. Personally I'm fine either way, since we're beginning to build up a good amount of info that solves real problems. Do we want to keep going in this fashion, or should we split the Steam pages up between the general page/installation, client troubleshooting, and game-specific troubleshooting? — Zlg (talk) 07:21, 4 April 2016 (UTC)

I agree the page is getting very long. I was planning on moving the client and games troubleshooting to their own sub-pages. Feel free to move them yourself.--BT (talk) 07:40, 4 April 2016 (UTC)
I have moved the client and games troubleshooting sections to their own sub-pages.--BT (talk) 00:47, 6 April 2016 (UTC)

Emerge -an @steam

Talk status
This discussion is done.

I'm new to Gentoo however I might have a possible improvement to this section. With emerge -a I got

Total: 35 packages (4 new, 1 in new slot, 30 reinstalls), Size of downloads: 116,079 KiB

which is pretty extreme (it even wanted to reinstall gcc, glibc etc). I read man emerge and found the --noreplace (-n) option which helped a lot

Total: 5 packages (4 new, 1 in new slot), Size of downloads: 4,478 KiB

Is this right? I'm new to the Wiki and am not sure how to make a clean edit. --Fcl (talk) 09:49, 19 April 2016 (UTC)

Well spotted! You are correct, the --noreplace option will cause Portage to skip already installed packages. I will make the edit. Thank you.--BT (talk) 10:29, 19 April 2016 (UTC)

end-user feedback

Talk status
This discussion is done.

Followed instructions from the wiki and encountered Blocked packages when `emerge --ask --changed-use --deep @world` is invoked with set `sets` and `package.use`.

[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-3.2.5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-239:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-232:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-fs/udev-232:0/0[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-3.2.5:0/0::gentoo, installed) pulled in by
    >=sys-fs/eudev-2.1.1 required by (virtual/udev-217:0/0::gentoo, installed)

Recommends adding troubleshooting for this issue. Fixed it by adding `sys-fs/udev` to `package.mask` posibly just adding warning about it? around invoked command?

--Kreyren (talk) 19:10, 17 September 2018 (UTC)

This has nothing to do with Steam itself. It is an unforunate bug in emerge. Closing discussion. --Grknight (talk)

Steam-overlay is superior

Talk status
This discussion is done.

BT - Recommends moving steam-overlay over manual version since it has issues with controller detection, stability issues and steam-overlay seems to have more efficient support from the maintainer.

Also generaly it's recommended to use ebuild over manual.

--Kreyren (talk) 20:25, 24 September 2018 (UTC)

External repositories are now preferred over manual installation.
--BT (talk) 00:20, 25 September 2018 (UTC)
BT - Note that external installation does NOT require sets and use flags.
--Kreyren (talk) 07:31, 25 September 2018 (UTC)
There is an exiting note about the dependency set not being required when using external repos. I have merged the note you added with the existing one.
--BT (talk) 10:41, 25 September 2018 (UTC)

Missleading info

Talk status
This discussion is done.

Steam#Prerequisites is not relevant for an overlay.

-- Kreyren (talk) 22:10, 7 December 2018 (UTC)

There is clearly an existing note regarding overlay dependencies and USE flags. You added the note, and I later edited it. There is nothing misleading about it.--BT (talk) 23:01, 7 December 2018 (UTC)

layout.conf not pulled from github

Talk status
This discussion is done.


Steam#anyc.27s_Steam_repository does not work as mensioned.

-- Kreyren (talk) 22:09, 7 December 2018 (UTC)

Unfortunately, you seem to miss the error output with the clear solution presented at that time.
!!! Command not found: git
!!! Type "emerge dev-vcs/git" to enable git support.

--Grknight (talk) 00:45, 9 December 2018 (UTC)

possible dependency sys-libs/nss_wrapper

starting steam failed for me with download errors until sys-libs/nss_wrapper was installed on the system, so it might be a required dependency

[2019-08-03 12:25:14] Downloading manifest:
[2019-08-03 12:25:14] Download failed: http error 0 (
[2019-08-03 12:25:14] Downloading manifest:
[2019-08-03 12:25:15] Download failed: http error 0 (

full startup log: Ben mkiv (talk) 10:56, 3 August 2019 (UTC)

x11-drivers/nvidia-drivers ABI_X86="32 64" USE=multilib

Consider adding x11-drivers/nvidia-drivers to the the list of packages that require abi_x86_32, and ensure it's installed with USE=multilib.

Without it opengl is broken.

Improvement to multilib warning?

Talk status
This discussion is done.

When I first tried to follow the instructions on this page the warning about the need for a multilib profile sent me on a huge diversion. Now that amd64 profiles are by far and away the most common, and multilib support is as simple as adding the appropriate USE flag for the packages affected (and emerge will tell you which) thanks to the Gx86-multilib project, shouldn't we say something to that effect so as not to deter relative noobs such as myself :o)

Diem (talk) 22:31, 28 March 2020 (UTC)

I supposed the link to the multilib page can be removed. Instead we can mention some multilib profiles such as default/linux/amd64/17.1, default/linux/amd64/17.1/desktop/gnome or default/linux/amd64/17.1/desktop/plasma and how to set them with eselect profile. I think the the dependencies and USE flag sections should also be moved the Manual installation section, since they're only relevant to that installation method.--BT (talk) 00:32, 30 March 2020 (UTC)
Actually my thought is that instead we leave the multilib text as-is, but add the following in parentheses after amd64: "(that is, during Gentoo installation you did not select the no-multilib option when choosing your profile)". I agree with your second suggestion to a great extent, however shouldn't we then also add a warning in the Installation section that emerge is going to issue repeated dependency errors for whatever list of libraries do need the abi_x86_32 USE flag? I definitely had that experience for a few libraries that aren't in the list on the page as it stands.--Diem (talk) 03:31, 9 April 2020 (UTC)
I agree with your suggestions. Feel free to make the necessary changes. When you're done I will move the dependencies and USE flag sections, but first I'd like to see if it's possible to collapse/hide the list as it's quite large.--BT (talk) 09:59, 9 April 2020 (UTC)
Thanks, my suggested changes are now done. In order to add the note concerning 32 bit dependencies potentially not included in the Proton runtime I had to refactor the External Repositories section to move the emerge instruction to it's own subsection. All ready now for you to move the Dependencies section into the Manual Installation section, along with removing the related Note from the Prerequisites section.--Diem (talk) 16:59, 12 April 2020 (UTC)
Done.--BT (talk) 02:08, 13 April 2020 (UTC)

Vulkan as a system dependency for steam-overlay installations?

Talk status
This discussion is done.

I found that when I installed games-util/steam-launcher and games-util/steam-client-meta from steam-overlay, Windows-only games (well, Terraforming Mars) wine would crash on launch with an enigmatic 'wine: Unhandled exception 0x20474343' error until I compiled in Vulkan support to Mesa as per the Vulkan wiki page. The corollary is that the Steam client runtime does not include mesa and depends on the one supplied by the system, so should this additional info be added to this page since it relates to the wine bundled with the client, rather than to a specific game?

Diem (talk) 22:31, 28 March 2020 (UTC)

Good to know. It may be something to add to either the Steam/Client troubleshooting or the Steam/Games troubleshooting sub-page. --Maffblaster (talk) 18:12, 10 April 2020 (UTC)
Yes, good point, I'll look at adding it there not here.--Diem (talk) 16:59, 12 April 2020 (UTC)

Additions to chroot chapter

Talk status
This discussion is still ongoing.

I had problems with audio/pulseaudio, so I had to adjust the provided chroot-wrapper script (thanks for that nice helper!), perhaps it is worth to mention here. (

mount --bind /var/lib/dbus "${chroot_dir}/var/lib/dbus"
mount -vR /dev/shm "${chroot_dir}/dev/shm"
mount --bind /<your_home_folder>/.config/pulse/ "${chroot_dir}/home/steam/.config/pulse"
mount -vR /tmp "${chroot_dir}/tmp"
mount --bind /<your_home_folder>/.pulse-cookie "${chroot_dir}/home/steam/.pulse-cookie"

Another source of problems were missing useflags like pulseaudio ^^ in the chroot environment.

If you use the chrootjail for other games/purposes, like lutris, you can find here a nice hint for doing the mounting via init script. Otherwise, if you quit steam, the umount will run and possibly break other applications. Chroot#Init_scripts

I also had to change the steam command in the script "${chroot_arch}" chroot "${chroot_dir}" su -c 'XDG_RUNTIME_DIR=/run/user/1000 steam' steam -

Kaffee (talk) 11:25, 29 April 2020 (UTC)

User namespace kernel builtin required for proton

Talk status
This discussion is done.

For a while any proton games running thru proton would crash on startup, with no log. Steam itself logged that bwrap required kernel namespaces but I found no metion of that on the wiki.

Enabling user namespaces instantly fixed the issue I was having and I am thinking it would be worth a mention. I also enabled memcg as was reccomended by the menuconfig namespace help page.

I found this information nowhere on either the wiki or even forums, though I may have missed it in the forums. I also didn't find it on steam. It's a simple fix that could just be added to the "Kernel" section of the wiki page.

-- Ahhzee (talk) 18:55, 23 July 2021 (UTC)

Done. --Winterheart (talk) 19:49, 4 May 2023 (UTC)

Prompt users to enable d3d9 useflag for mesa

Talk status
This discussion is still ongoing.

On my system, mesa's d3d9 useflag is disabled by default.

And when I launched games using proton, it will simply quit without any clues, since mesa doesn't support dxvk without the useflag.

So, I think it might be a good idea to remind users to enable the d3d9 useflag so that they won't waste time debugging what caused their game to stop working.

--Juancc (talk) 06:07, 25 April 2022 (UTC)

Sounds like a good idea. Feel free to add a section to one of the Steam troubleshooting pages ;). Gentoo_Wiki:Contributor's_guide.
Thanks for the comment, even if nothing is added to the article, this discussion may help some people. -- Ris (talk) 07:12, 1 May 2022 (UTC)

Removing manual installation section

Talk status
This discussion is still ongoing as of 2023-05-04.

Since for user no benefits at all on choosing manual installation over steam overlay, I propose to delete Manual installation section. --Winterheart (talk) 20:08, 4 May 2023 (UTC)

Maybe, I really couldn't say. I just wanted to suggest that perhaps we could move it to a sub article? If we have working information on the wiki, it always seems a shame to remove it, even if it isn't that useful - I usually prefer to move things to one side and put harder warnings on them. -- Ris (talk) 20:14, 4 May 2023 (UTC)

Enable abi_x86_32 flag for dev-lang/rust

Talk status
This discussion is still ongoing as of 2024-03-29.

I found a problem while emerging Steam: apparently a component couldn't compile because there was no support for i686-unknown-linux-gnu. Should this be added to the list of dependencies' local USE flags? -- Motodavide

Please be clearer and file a bug report if you believe this to be real issue. -- Chewi (talk) 13:37, 30 March 2024 (UTC)
I'm sorry, I don't believe it's a bug: I simply merged dev-lang/rust (not the binary package) without the aforementioned flag and I couldn't compile some components due to the lack of support for the i686-unknown-linux-gnu architecture. Adding the flag solved the issue. I was wondering, before making an edit to the wiki, if this is a potential package USE flag to add to the list for preventing other users to have the same problem as me. -- Motodavide
Okay, but which packages actually fail to build? We can often enforce these things with USE dependencies. -- Chewi (talk) 19:38, 1 April 2024 (BST)
The package was x11-libs/extest -- Motodavide