ATI FAQ

From Gentoo Wiki
Jump to:navigation Jump to:search
This page is a translated version of the page ATI FAQ and the translation is 11% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎italiano • ‎русский • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어


Diese FAQs sollen Anwendern dabei helfen, die häufigsten Probleme im Zusammenhang mit DRI und X11 für AMD/ATI-Karten zu vermeiden.

Wird meine AMD/ATI Karte unterstützt?

Viele AMD/ATI Karten werden von xorg-x11 unterstützt, zumindest jedoch die 2D-Beschleunigung. Die 3D Unterstützung wird entweder durch xorg-x11 oder mit AMD's closed source drivers bereitsgestellt. AMD's proprietäre Treiber unterstützen allerdings nur R600 und neuere GPUs. Ältere GPUs nutzen den quelloffenen xorg-x11 Treiber.

GPU Gebräuchlicher Name Support
Rage128 Rage128 xorg
R100 Radeon7xxx, Radeon64 xorg
R200, R250, R280 Radeon8500, Radeon9000, Radeon9200 xorg
R300, R400 Radeon 9500 - X850 xorg
R500 Radeon X1300 - X1950 xorg
R600 RadeonHD-2000-Serie xorg
RV670 RadeonHD 3000-Serie xorg
RV770 (R700) RadeonHD-4000-Serie xorg
Evergreen RadeonHD-5000-Serie AMD DRI, xorg
Northern Islands RadeonHD-6000-Serie AMD DRI, xorg
Southern Islands RadeonHD-7000-Serie AMD DRI, xorg
1 Experimental, optional support since kernel 4.9-rc1
Notiz
Die Radeon Feature Matrix auf x.org führt den Grad der Opensource Treiberunterstützung für jeden Teil der Grafikkartenhardware auf.

Ich habe eine All-In-Wonder/ Vivo Grafikkarte. Werden die Multimedia-Funktionen unterstützt?

Nothing special is necessary for the board's multimedia features; x11-drivers/xf86-video-ati should work.

I'm not using an x86-based architecture. What are my options?

X11 support on the PPC or alpha platforms is quite similar to x86\amd64 X11 support. However, AMD/ATI's closed source Catalyst drivers are not supported on the PPC or Alpha, the open source drivers are the only option on these platforms. The Catalyst drivers are only available for x86 and AMD64. The open source xorg-x11 drivers should work well on all architectures.

Wichtig
To enable agpgart support for certain old AMD64 chipsets, support for K8 IOMMU must be disabled.

Are ATI Mobility models supported?

They should be, but there may be a configuration issue due to the OEM PCI ID on certain chips. In such cases the configuration file may need to be manually written.

See also

External resources

  • Wedge Unofficial Gentoo ATI Radeon FAQ
  • Unofficial AMD Linux Driver Wiki
    This page is based on a document formerly found on our main website gentoo.org.
    The following people contributed to the original document: Luca Barbato, Jorge Paulo, Tiemo Kieft, Joshua Saddler
    They are listed here because wiki history does not allow for any external attribution. If you edit the wiki article, please do not add yourself here; your contributions are recorded on each article's associated history page.