Talk:Intel

From Gentoo Wiki
Jump to: navigation, search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

Rename to xf86-video-*

Talk status
This discussion is done.

Intel sounds a little ambiguous, especially if we'd like to add something about Intel CPUs or so on. Maybe it'd be better to rename this to xf86-video-intel or like that? -- MGorny 06:57, 19 October 2011 (UTC)

That's the name of the driver. Also the man page is named like this. Astaecker 08:58, 19 October 2011 (UTC)
Even though the name may be unambiguous in the context of graphics drivers, it's not in the context of gentoo. +1 from me for the name change to what the package is named in gentoo. --Few 09:30, 19 October 2011 (UTC)
How about moving it to "X/Intel"? /Ni1s 21:45, 24 October 2011 (UTC)
In the interest of avoiding strange hierarchies I suggest either "xf86-video-intel" or something like "Intel (Xorg driver)". Eroen

Ivy Bridge OpenCL support

Talk status
This discussion is done.

With regards to this edit: Ivy Bridge -- the hardware -- supports OpenCL, but there isn't any software support for it in Linux at this time. --Mattst88 19:03, 29 December 2012 (UTC)

I added a note
Astaecker 07:45, 30 December 2012 (UTC)

mesa broken

Talk status
This discussion is done.

When following the directions laid out by this wiki, I found that dri was broken. To fix this I added a line to package.use >=media-libs/mesa-10.0.3 video_cards_i915 video_cards_i965 video_cards_intel gallium vdpau amd then ran emerge --changed-use =media-libs/mesa-10.0.3 This game me;

  1. ldd /usr/lib/mesa/i965_dri.so
       linux-vdso.so.1 (0x00007ffff49ff000)
       libdrm_intel.so.1 => /usr/lib64/libdrm_intel.so.1 (0x00007f59c448f000)
       libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f59c4283000)
       libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f59c4058000)
       libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f59c3e3a000)
       libdl.so.2 => /lib64/libdl.so.2 (0x00007f59c3c36000)
       libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/libstdc++.so.6 (0x00007f59c3932000)
       libm.so.6 => /lib64/libm.so.6 (0x00007f59c362f000)
       libc.so.6 => /lib64/libc.so.6 (0x00007f59c3287000)
       libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/libgcc_s.so.1 (0x00007f59c3070000)
       libpciaccess.so.0 => /usr/lib64/libpciaccess.so.0 (0x00007f59c2e67000)
       /lib64/ld-linux-x86-64.so.2 (0x00007f59c4d4e000)
       libz.so.1 => /lib64/libz.so.1 (0x00007f59c2c50000) 

Problem solved. It might be a good idea to update this wiki with the use settings for mesa.

"intel" USE flag

Talk status
This discussion is done.

In the features support table the "intel" USE flag is listed for all 7 generations. In the driver section the "intel" USE flag is used only for generations 1-2. This is contradictory. Unfortunately I don't know which configuration is the right one. Fturco (talk) 13:49, 16 March 2014 (UTC)

https://wiki.gentoo.org/index.php?title=Intel&action=history above "talk" poster gave me ssh to their box, set, tested, and they confirmed intel is not required for their gen 3+ hardware. they had i915, and got some error messages regarding 965. i would of linked against a forum thread but lost it and the search on forums is absolutely horrible. 666threesixes666 (talk) 21:11, 18 March 2014 (UTC) remove the intel and further test it.
09:13, 16 January 2013‎ Astaecker (Talk | contribs)‎ . . (3,525 bytes) (+522)‎ . . (Add "VIDEO_CARDS" column to feature matrix; inline inflexible {{VIDEO_CARDS}} template for proper step to step instructions) looks like they are template examples, and not necessarily tested. 666threesixes666 (talk) 21:14, 18 March 2014 (UTC)
it occured to me that i had a POS blade, and that it might have intel graphics. i plug it in, it has i915. so i test it, and i reverted something i shouldn't of. libdrm requires the intel flag. regardless, the wiki can be flawed, but the os will tell you what is what. this is coming from a fresh build of gentoo, and not a mangled revdep rebuild, or emerge -uND @world. 666threesixes666 (talk) 02:59, 19 March 2014 (UTC)

CONFIG_FRAMEBUFFER_CONSOLE=y

Talk status
This discussion is done as of May 16, 2017.

Still gives black screen after grub on my Thinkpad x220. 4.3.2 kernel. Upd: but adding acpi_osi="Linux" solves the issue. --Dtr (talk) 12:44, 16 December 2015 (UTC)

Feel free to add this to the article. No discussion necessary. --Maffblaster (talk) 18:31, 16 May 2017 (UTC)

Introduce instructions to omit xf86-video-intel on Gen 4+

Talk status
This discussion is done.

Other distros have started phasing out xf86-video-intel in favor of the modesetting driver which the latter is more advanced on Gen 4 and later Intel GPUs (see https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-Debian-Abandon-Intel-DDX) Should we provide instructions to this effect here? --Grknight (talk) 14:36, 16 August 2016 (UTC)

Based on a discussion in #gentoo-wiki this change would add the following to /etc/portage/package.use:
FILE /etc/portage/package.use
x11-base/xorg-drivers VIDEO_CARDS: -intel
This would migrate the x11-base/xorg-drivers package to use currently developed x11-drivers/xf86-video-modesetting instead of the stagnant x11-drivers/xf86-video-intel package. Should work nicely for all core processors.
I will test on my system, but I trust Brian's judgement so I'm not opposed to making the change. --Maffblaster (talk) 17:03, 16 August 2016 (UTC)
Blackb|rd on IRC pointed out that brightness controls may be an issue for laptops as x11-apps/xbacklight does not work with modesetting (see https://bugs.freedesktop.org/show_bug.cgi?id=96572). https://github.com/wavexx/acpilight/ might be a replacement but needs packaging.
I tested:
FILE /etc/portage/make.conf
VIDEO_CARDS="-intel"
And I get Invalid '-' operator in non-incremental variable 'VIDEO_CARDS': '-intel' on Portage 2.2.28. Next I tried setting it in /etc/portage/package.use as Grknight suggested above and that also didn't recognize the change... If I need to go to unstable Portage for this to work then I'd recommend not making the change until Portage can naively handle it. --Maffblaster (talk) 00:44, 20 August 2016 (UTC)
I've made the change with Portage 2.22.8 and with the exact same line given by Grknight ; followed by a emerge --depclean in order to actually remove the x11-drivers/xf86-video-intel package (which was pulled by x11-base/xorg-drivers when VIDEO_CARDS contained intel).
I've also activated the glamor USE flag for x11-base/xorg-server in order to fix warnings seen in Xorg.0.log: (EE) AIGLX: reverting to software rendering. Without it, programs requesting for hardware acceleration (like Firefox, 3D engines, ...) will fail to start/segfault or will fallback to software rendering.

VIDEO_CARDS for Q35 chipset

Talk status
This discussion is done as of 2017-04-26.

I have an Intel DQ35JO motherboard with integrated GPU. According to this Gentoo wiki article my GPU belongs to the 4th generation (chipset Q35), so I need to set VIDEO_CARDS="intel i965". But if I do that and re-emerge the mesa package X won't start anymore. Instead if I set VIDEO_CARDS="intel i915" everything works perfectly. According to this Wikipedia article the Q35 chipset belongs to the 3rd generation, not the 4th one. Can anyone confirm this? Can I update the feature support table in the this Gentoo wiki article according to my findings? Please see the following forum threads for further details:

It seems G35 belongs to the 4th GPU generation while Q35 belongs to the 3rd one. This explains everything. Article fixed. Fturco (talk) 16:01, 26 April 2017 (UTC)

Wayland

Talk status
This discussion is still ongoing.

This partially connects to phasing out `xf86-video-intel`, as for Wayland you only need `mesa` with EGL support.

Mesa has a ton of use flags though. Would be nice to figure out what is the minimal/optimal set to get things going.

Hi, Lkraav , I agree. We'll probably need one of the package maintainers to step up the game on telling us all how to get wayland working. I heard that it can be as simple as enabling the wayland USE flag globally, but I haven't tried it yet. Also, please be sure to sign you comments on discussion pages. Thanks! --Maffblaster (talk) 08:10, 13 December 2016 (UTC)