Talk:Arduino

From Gentoo Wiki
Jump to:navigation Jump to:search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

Issue with Arduino IDE software

Talk status
This discussion is done as of May 3, 2017.

I have the same issue as one here: http://arduino.stackexchange.com/questions/19310/cannot-find-crtatmega328p . You should change this wiki page according to changes and problems when one want to install arduino IDE software. Sorry, I forgot to sign my comment. --Best, Pál (talk) 17:40, 29 February 2016 (UTC)

Hi Csanyipal, I don't have an Arduino or else I might be able to help. Please remember to sign your comments when leaving messages on talk pages. --Maffblaster (talk) 06:44, 29 February 2016 (UTC)
I just emerge arduino again ( did unmerged it before ).
I open a project into Arduono IDE and want to verify it, but get error message:
/usr/libexec/gcc/avr/ld: cannot find crtatmega328p.o: No such file or directory.
/usr/libexec/gcc/avr/ld: cannot find -latmega328p
collect2: error: ld returned 1 exit status
What can I do to solve this problem? --Best, Pál (talk) 20:30, 1 March 2016 (UTC)
Finally I managed to get working arduino IDE on my Gentoo system. I add tinfo USE flag to the sys-libs/ncurses package, then re-emerge it and now Arduino IDE works out here. --Best, Pál (talk) 19:43, 8 March 2016 (UTC)
Please update the article if instructions were incorrect. This is a place to discuss documentation changes before making them (or if someone reverts your edit). Support can be provided on the Forums or IRC. Nothing left to discuss here. Kind regards, --Maffblaster (talk) 00:22, 4 May 2017 (UTC)
I have the same problem, i changed to "+" tinfo use flag on ncurses, but it is still not working. --Juan Facundo Suárez 10:27 -03:00 , 13/06/2017
I could solve this, deleting '--stable' part of crossdev command line, from arduino wiki: https://wiki.gentoo.org/wiki/Arduino#Install_the_toolchain_using_crossdev on gentoo wiki, so the command line was:
USE="-openmp -hardened -sanitize -vtv" crossdev -s4 --portage --verbose --target avr
this solved it for me. --Juan Facundo Suárez 22:51 -03:00 , 13/06/2017
I also had to add -mpx:
USE="-openmp -mpx -hardened -sanitize -vtv" crossdev -s4 --stable --portage --verbose --target avr
--Sorin Pânca 09:20 +02:00 , 01/06/2018

Arduino Zero

Talk status
This discussion is still ongoing as of Oct 31, 2021.

The kernel driver for Arduino Zero is also CDC ACM. Could you, please, update the page with this information.

Thanks.

Bugalo (talk) 10:53, 31 October 2021 (UTC)

Does this edit fix this ? -- Kyoreln (talk) 14:35, 31 October 2021 (UTC)