From Gentoo Wiki
Jump to:navigation Jump to:search
Before creating a discussion or leaving a comment, please read about using talk pages. To create a new discussion, click here. Comments on an existing discussion should be signed using ~~~~:
A comment [[User:Larry|Larry]] 13:52, 13 May 2024 (UTC)
: A reply [[User:Sally|Sally]] 17:48, 15 July 2024 (UTC)
:: Your reply ~~~~


Talk status
This discussion is done.

"AMDGPU with Display Core works primarily for VEGA10 (GCN5.0) and RAVEN (with DCN 1.0) GPUs/APUs. Older cards (GCN1.1 and newer) can be activated in the kernel or using the kernel command line option amdgpu.dc=1 and provide better (but experimental) support than the older radeon kernel module. "

Is this still accurate? I read in this Phoronix article that amdgpu.dc=1 has become default since kernel 4.17 for pre-Vega hardware.

AndrewAmmerlaan (talk) 17:43, 26 April 2020 (UTC)

I agree. Done. Luttztfz (talk) 12:27, 29 April 2020 (UTC)

TAHITI firmware files needed for other Southern Island chipsets?

Talk status
This discussion is done as of 2021-12-16.

The lists of firmware files needed for the Southern Islands chipsets (Cape Verde, Pitcairn, etc.) all include TAHITI_uvd.bin TAHITI_vce.bin, but I've booted a kernel without including those firmware files and it works fine, with no messages in dmesg or syslog about missing firmware. This could be specific to my hardware; I use a Radeon HD 7850 card. But could it be that the TAHITI files are not needed? The firmware file lists were copied from the radeon article, but I'm not sure if anyone has actually checked whether AMDGPU has the same firmware requirements.

Here are the revisions where the TAHITI files were introduced in the radeon article:

There are also discussions about this on the talk page for radeon:

DavidZaslavsky (talk) 22:37, 31 January 2017 (UTC)

Unfortunately I do not have the hardware to test and it would appear others who have visited this article haven't tested either. Since your discussion hinges on specific hardware, it's not really practical for myself (or apparently others) to know either way. This discussion has been open for several years, I am going to close it. If you ever find out the answer, please update the appropriate article with your findings. Thank you! --Maffblaster (talk) 00:07, 18 December 2021 (UTC)

Where is the Enable AMD powerplay component Option

Talk status
This discussion is done.

I filed a bug on bugs.gentoo asking what this option is called. I was referred here. I did try the kernel's search feature. I tried it with the gentoo-sources-4.9.x series which is what the user is using in this article. Thanks — The preceding unsigned comment was added by Ballsystemlord (talkcontribs)

It appears this used to be an optional component, but became required for later versions of AMDGPU, so the Kconfig entry was removed altogether. We should probably remove that line from the page. I took the liberty of removing it myself since it's a simple fix. --Spork kitty (talk) 04:45, 23 February 2019 (UTC)

Possibly more Firmware needed for Radeon RX5xx series

Talk status
This discussion is done as of 30 July 2020.

It seems that the old listing is not enough - at least as of Kernel 4.17.15 and =sys-kernel/linux-firmware-20180730 these chips need more firmware at boot time. At least with the current setup boot failed with an active, but blank screen an mostly unresponsive system (I think it stalled like usual in this case for ~1 minute, then booted "headless" and I could REISUB).

New list for an RX560 should at least include amdgpu/polaris11_ce.bin amdgpu/polaris11_me_2.bin amdgpu/polaris11_pfp.bin amdgpu/polaris11_smc.bin amdgpu/polaris11_ce_2.bin amdgpu/polaris11_mec.bin amdgpu/polaris11_pfp_2.bin amdgpu/polaris11_smc_sk.bin amdgpu/polaris11_k_smc.bin amdgpu/polaris11_mec2.bin amdgpu/polaris11_rlc.bin amdgpu/polaris11_uvd.bin amdgpu/polaris11_mc.bin amdgpu/polaris11_mec2_2.bin amdgpu/polaris11_sdma.bin amdgpu/polaris11_vce.bin amdgpu/polaris11_me.bin amdgpu/polaris11_mec_2.bin amdgpu/polaris11_sdma1.bin

(Aug. 19th, 2018) I checked with this newly extended set of FW and it boots up nicely.

--Adarion (talk) 17:38, 17 August 2018 (UTC)

I'm glad you solved your own problem, Adarion. Good work! --Davidbryant (talk) 17:14, 30 July 2020 (UTC)

Kernel configuration

Talk status
This discussion is done.
Device Drivers  --->
    Generic Driver Options  --->
        -*- Userspace firmware loading support

Userspace firmware loading support ǃ= present in 4.18.9-gentoo.


Device Drivers  --->
    Generic Driver Options  --->
        [*] Include in-kernel firmware blobs in kernel binary
            (amdgpu/<YOUR-MODEL>.bin or radeon/<YOUR-MODEL>.bin)
            (/lib/firmware) Firmware blobs root directory

Include in-kernel firmware blobs in kernel binary ǃ= present in 4.18.9-gentoo. --Kreyren (talk) 12:12, 27 September 2018 (UTC)

Those pesky kernel developers changed the menus again. ;) But, it is not much of a stretch to see the important options are now under the "Firmware loader" sub-menu. Such is the problem of documenting software, it is outdated the moment you publish it. --Grknight (talk) 20:57, 7 November 2018 (UTC)
New KernelBox included --Grknight (talk) 21:12, 7 November 2018 (UTC)

Use flags

Talk status
This discussion is done.


Package x11-drivers/xf86-video-amdgpu doesn't have any mentioned USE flag. `amdgpu` should be mensioned.

--Kreyren (talk) 12:12, 27 September 2018 (UTC)

x11-drivers/xf86-video-amdgpu does have a udev USE flag. Unfortunately, this information is automatically generated and cannot be added by hand. This keeps some data fresh as update but is far from perfect. --Grknight (talk) 20:54, 7 November 2018 (UTC)

Provide accurate informations!

Talk status
This discussion is done.

To Brian Evans (Grknight) -

Is missleading since this "fix" was proved as non-functional on mensioned bug.

-- Kreyren (talk) 17:31, 15 October 2018 (UTC)

Removed section that is no longer an issue as the offending version was removed. --Grknight (talk) 21:01, 7 November 2018 (UTC)

Writing style

Talk status
This discussion is done as of 2021-12-16.

I find the firmware instructions unnecessarily hard to understand. I suggest rewriting this section along the following lines:

  1. The simplest way to ensure loading of firmware is to designate amgdpu as a module. As soon as udev loads it the necessary firmware will also be loaded assuming that it is available to load, either from an initramfs or from the designated firmware location on the filesystem
  2. If you want to build in the amdgpu driver you need to also build in the necessary firmware files

That is, I hope the above is correct (at least it works for me).

DolderBoy (talk) 08:25, 28 September 2020 (UTC)

Sounds good. You may implement the suggestion in the main article at any time. --Maffblaster (talk) 00:09, 18 December 2021 (UTC)
Assumption 2 is wrong. The firmware is not necessary for building the amdgpu driver (i.e. build time), instead when loading the driver the appropriate firmware needs to be available (i.e. run time).
Loading the driver as a module has caveats as well, e.g. an other (generic) driver must additionally be available to get early boot time graphics (boot messages/printk or a boot splash screen).
But, please, making it less complicated and hard to understand is highly appreciated.
Luttztfz (talk) 13:59, 18 December 2021 (UTC)

Navi 33

There is a list of Navi 33 firmware in a forums post

It would be good to add that but my wiki foo is weak. I'll try if someone else will check it.

--NeddySeagoon (talk) 09:30, 10 September 2023 (UTC)

HWCursor on RDNA3

Talk status
This discussion is done as of 2023-10-11.

Hardware cursor doesn't work on Xorg with RDNA3 cards. I guess, there should be remark about configuration of software cursor in 20-amdgpu.conf. — The preceding unsigned comment was added by Necromant41 (talkcontribs) 2023-10-01T11:14:14‎

Thanks for the heads-up Necromant41 . Do you have a solution to this issue? If so, please could you add it to the article? If the issue remains, you could contact support and come back here to fix the article once you know how to resolve it. If the issue doesn't have a current solution, it could be useful to just add a temporary warning about it to the article. Thanks. -- Ris (talk) 23:16, 1 October 2023 (UTC)
I've just added it. If the text is okay (from point of wiki), i guess the discussion should be closed. -- Necromant41 19:40, 11 October 2023 (UTC)

Radeon Pro WX3200

Talk status
This discussion is done as of 2024-03-31.

Just wanted to note that I was able to get this card working using the instructions listed here. I would add it to the table but not sure exactly where it should go. Is there anything I can add with respect to what firmware it uses etc.?

-- Gpk (talk) 19:43, 5 January 2024 (UTC)

I have gone ahead and made some changes myself. Since this is my first wiki edit of this kind I would welcome any feedback. -- Gpk (talk) 12:17, 6 January 2024 (UTC)
Looks good to me!
Thanks for your contribution. Don't be afraid to contribute without starting a new discussion — there will always be someone who looks at your edit, and if they see a mistake, they will probably fix it in seconds. Waldo Lemmer (talk) 10:45, 31 March 2024 (UTC)