Talk:Xfce

From Gentoo Wiki
Jump to: navigation, search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

UNEMERGEFULL!

Talk status
This discussion is still ongoing as of 17 September 2018.

https://wiki.gentoo.org/wiki/Xfce#Emerge is unemergefull.. Someone should update it so that it doesn't have wrong commands and is simple to understand.

Can't do it by myself since it's indexed.

--Kreyren (talk) 15:37, 17 September 2018 (UTC)

Kreyren , you're going to need to be a little more clear regarding what you want changed. Title's like "UNEMERGEFUL" are not descriptive. Also, don't forget to use the {{Talk}} template when you open new discussions so that they can be tracked. I have added the template for you this time. --Maffblaster (talk) 16:46, 17 September 2018 (UTC)
Matthew Marchese (Maffblaster) ː Noted

1) It's recommended to invoke `emerge --ask xfce-base/xfce4-meta xfce-extra/xfce4-notifyd` followed by `emerge --ask --deselect=y xfce-extra/xfce4-notifyd` which is uneffective i believe. End-user should be informed only to invoke `xfce-base/xfce4-meta` and as addition to that `xfce-extra/xfce4-notifyd` and the rest with additional informations.

2) `emerge --ask xfce-base/xfwm4 xfce-base/xfce4-panel` where `xfce-base/xfwm4` is invalid afaik.

--Kreyren (talk) 17:58, 17 September 2018 (UTC)

Got it. It's been a while since I installed XFCE, so probably these instructions need updated. You can update them if you want to take the time to install XFCE. :) --Maffblaster (talk) 18:02, 17 September 2018 (UTC)
Matthew Marchese (Maffblaster) ː Ok fix indexing after plz i've just installed xfce4 on `Tomiska` (1core at 1,42Ghz notebook with docking station running gentoo to run PS2 emulator) so i add more things if neccesary.

Or mby can you provide me the instructions to indexing? Or like are they even neccesary?

--Kreyren (talk) 18:34, 17 September 2018 (UTC)

EDITː xfce-base/xfwm4 it included in gentoo repo, but wasn't when i emerge it on Tomiska.. Possibly not available on i686 ? Verifing now

Suggested edit archiveː

It is time to install the complete Xfce desktop! Without explicitly including {{Package|xfce-extra/xfce4-notifyd}} in the {{c|emerge}} command, {{Package|virtual/notification-daemon}} will draw in GNOME's {{Package|x11-misc/notification-daemon}} instead. So install it together with {{Package|xfce-base/xfce4-meta}} and later deselect it so it is not included in the world file: {{Emerge|xfce-base/xfce4-meta xfce-extra/xfce4-notifyd}} OR {{Emerge|xfce-base/xfce4-meta}} ==== OLD VERSION ====

xfce-base/xfwm4 is available in gentoo repo on amd64 and i686. (my bad? It wasn't when i tried to emerge it before..)


Well i would at least recommend adding explanation to what is the difference between xfce-base/xfwm4 and xfce-base/xfce4-meta otherwise solved.

--Kreyren (talk) 18:42, 17 September 2018 (UTC)

xarchiver is not available in the Portage tree

Talk status
This discussion is done.

Excuse me my English (that is why I write comment, not trying to update article) Article needs in update. xarchiver is outdated and AFAIR already removed from tree.

For just now Thunar's feature of custom actions together with commandline archive tools could be used instead. I have to have exec startxfce4 --with-ck-launch in ~/.xinitrc for the restart/shutdown/suspend/hibernate buttons to work in XFCE4. Perhaps it could be mentioned in the article. --Renergy (talk) 20:09, 11 June 2015 (UTC)

Hi, Renergy! I checked on my system and it looks like xarchiver is still available in Portage. I will look into the --with-ck-launch option you used to start Xfce. I believe this is needed if the consolekit USE flag has been set on the login manager. :) --Maffblaster (talk) 01:06, 24 December 2015 (UTC)

Bug #498436

Talk status
This discussion is done.

As of writing, the result of bug bug #498436, having confused 'dconf' and 'dbus', apparently for the sake of allowing GNOME people to write sloppier ebuilds, forces dconf for virtually everyone using glib regardless of using GNOME or not. Putting glib into an overlay for the time being using the following patch will avoid the issue until it's properly resolved:

--- /usr/portage/dev-libs/glib/glib-2.46.2-r2.ebuild    2016-03-01 09:11:54.000000000 -0800
+++ /usr/local/portage/dev-libs/glib/glib-2.46.2-r2.ebuild      2016-03-01 19:10:38.993947815 -0800
@@ -26,7 +26,7 @@
 
 LICENSE="LGPL-2+"
 SLOT="2"
-IUSE="dbus fam kernel_linux +mime selinux static-libs systemtap test utils xattr"
+IUSE="dbus dconf fam kernel_linux +mime selinux static-libs systemtap test utils xattr"
 REQUIRED_USE="
        utils? ( ${PYTHON_REQUIRED_USE} )
        test? ( ${PYTHON_REQUIRED_USE} )
@@ -69,7 +69,7 @@
 # different g-i and glib major versions
 
 PDEPEND="!<gnome-base/gvfs-1.6.4-r990
-       dbus? ( gnome-base/dconf )
+       dconf? ( gnome-base/dconf )
        mime? ( x11-misc/shared-mime-info )
 "
 # shared-mime-info needed for gio/xdgmime, bug #409481
mousepad

Further, if you should want to use mousepad & have it work properly without dconf, you will want this ebuild patch:

--- /usr/portage/app-editors/mousepad/mousepad-0.4.0.ebuild     2015-08-08 17:38:18.000000000 -0700
+++ /usr/local/portage/app-editors/mousepad/mousepad-0.4.0.ebuild       2016-02-27 11:48:10.007781001 -0800
@@ -12,7 +12,7 @@
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="debug dbus gtk3"
+IUSE="debug dbus gtk3 +keyfile-settings"
 
 RDEPEND=">=dev-libs/glib-2.30:2=
        dbus? ( >=dev-libs/dbus-glib-0.100:0= )
@@ -31,6 +31,7 @@
                $(xfconf_use_debug)
                $(use_enable dbus)
                $(use_enable gtk3)
+               $(use_enable keyfile-settings)
                )
 
        DOCS=( AUTHORS ChangeLog NEWS README TODO )

— The preceding unsigned comment was added by Grknight (talkcontribs) 4 March 2016

Any discussion on this should be done here. Reisio , please discuss your reasoning for desiring this patch to be in the main Xfce article before moving it again. At least three Gentoo devs are unified on this point. --Maffblaster (talk) 00:32, 5 March 2016 (UTC)
Looking at the bug tracker, it looks like the bug was closed. Marking the discussion as closed. Also, please remember to sign your comments to discussion pages uses the "Signature and timestamp" button in the editor toolbox above. Kind regards, --Maffblaster (talk) 20:10, 30 December 2016 (UTC)
It comes as some relief to me that you have decided to stop talking with yourself. ¦ Reisio (talk) 01:55, 31 December 2016 (UTC)