Talk:Steam/Games troubleshooting

From Gentoo Wiki
Jump to: navigation, search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

Unity games issues

Talk status
This discussion is still ongoing.

As shown in this article, there had been some known issues with Unity games, such as the following;

"Many games that utilize the Unity3D engine released in late 2015 or later either display a black screen for a few seconds and segfault, or run but without sound"

In some cases, when you run steam from a terminal and launch Hollow Knight, for example, this will happen, as mentioned in this forum post: Steam doesn't want to launch most of my games

The game will attempt to load, segfault, and then kill itself before writing to a player.log file; The contents of which will pertain to an unsupported OpenGL version.

The solution, as posted in the same forum topic by Kajzer is passing an openGL 3.3 override in the launch options as follows:

MESA_GL_VERSION_OVERRIDE=3.3 MESA_GLSL_VERSION_OVERRIDE=330 %command%

After that was performed, I can confirm that this has worked for the following games:

  • Hollow Knight
  • Mother Russia Bleeds
  • Wizard of Legend
  • One More Dungeon
  • Slash or Die 2 (I accidentally set this language in ukrainian.)

The only game that this didn't work on was

  • Devil Daggers.

I want to start a list of unity games that this fix will work on in the future, as many developers that use unity implement linux support but almost never post about passing through OpenGL in launch options to make sure this works for everyone.

Furthermore, until Kajzer posted his launch option that fixed my games, I had not seen a SINGLE POST in the steam forums, Ubuntu forums, or even the Linux Gaming Subreddit that contained this solution.

When I reverse searched the command on google, I only found four (4) relevant forum topics that contained this solution for general Linux gaming. Unacceptable. — The preceding unsigned comment was added by Starrcade (talkcontribs) 11:14, 19 November 2018‎

Terraforming Mars

Talk status
This discussion is done.

After installing games-util/steam-launcher and games-util/steam-client-meta from anyc's steam-overlay, the game (or rather the wine install bundled with the Proton Steam client) would still not launch until I compiled in Vulkan support to Mesa as per this wiki page . If there is no objection I'll add a troubleshooting item for this game here as well as a more general item about Vulkan on the Steam client page, since it is arguable that people arriving here might consider it as a client or game issue.--Diem (talk) 22:57, 28 March 2020 (UTC)

Following Maffblaster's comment on the Steam talk page, I have added this troubleshooting item--Diem (talk) 17:24, 12 April 2020 (UTC)