Talk:/etc/portage/patches

From Gentoo Wiki
Jump to:navigation Jump to:search
Note
Before creating a discussion or leaving a comment, please read about using talk pages. To create a new discussion, click here. Comments on an existing discussion should be signed using ~~~~:
A comment [[User:Larry|Larry]] 13:52, 13 May 2024 (UTC)
: A reply [[User:Sally|Sally]] 13:25, 17 June 2024 (UTC)
:: Your reply ~~~~

Update for EAPI=6

Talk status
This discussion is done.

I think this needs to be updated for EAPI 6. I am getting this error when trying to update my system. I am not using any patches for this package.

* Running elibtoolize in: rtkit-0.11/
* ERROR: sys-auth/rtkit-0.11-r2::gentoo failed (prepare phase):
*   eapply_user (or default) must be called in src_prepare()!
* 
* Call stack:
*            ebuild.sh, line  780:  Called __ebuild_main 'prepare'
*   phase-functions.sh, line 1005:  Called __dyn_prepare
*   phase-functions.sh, line  380:  Called die
* The specific snippet of code:
*   		die "eapply_user (or default) must be called in src_prepare()!"

— The preceding unsigned comment was added by Rypervenche (talkcontribs)

It was a bug in the ebuild, bug #578624. — kensington

bashrc errors

Talk status
This discussion is done.

The /etc/portage/bashrc snippet as given yields the following errors:

/dev/fd/63: line 400: syntax error near unexpected token `fi'

/dev/fd/63: line 400: `fi #_EPATCH_ECLASS' — The preceding unsigned comment was added by PPed72 (talkcontribs) 06:12, 22 November 2017‎

Coding snippet has been removed.--Charles17 (talk) 07:24, 27 December 2019 (UTC)