Talk:ZoneMinder/Archive1

From Gentoo Wiki
Jump to: navigation, search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

Manually building zoneminder

Talk status
This discussion is done.

Hi!

I don't think manually building an application in Gentoo is appropriate. This is all that ebuild was designed for.

I don't know why it's not in the portage, but in the "zugaina" portage overlay there IS an almost working ebuild.

I suggest to mention on this page: (I don't have the courage to edit it myself, and I'm not quiet sure)

root #layman -a zugaina
root #layman -S

You have to put

FILE /etc/portage/env/www-misc/zoneminderspecial settings for the ebuild (hotfix?)
CXXFLAGS="-D__STDC_CONSTANT_MACROS -fpermissive"

Then:

root #emerge -av www-misc/zoneminder

should work fine!

All the things on the page about the shm, and the web server config is fine (in fact I didn't check it, but at first glance, it's complete)

DBLaci



Hi

Great job

I was very sad when the ebuild was removed

Nice to see other gentoo users use zoneminder

Maybe the ebuild will come back

Cheers

Nigel


Hi

I followed the guide.

I had to change some things around

uname -a
Linux r210 3.2.1-gentoo-r2 #3 SMP Thu Mar 1 08:19:31 EST 2012 x86_64 Intel(R) Xeon(R) CPU X3440 @ 2.53GHz GenuineIntel GNU/Linux
emerge -av dev-perl/DateManip

unmask LWP-UserAgent-Determined

emerge -av dev-perl/LWP-UserAgent-Determined
./configure --with-webdir=/var/www/localhost/htdocs/zm  --with-cgidir=/var/www/localhost/cgi-bin CPPFLAGS=-D__STDC_CONSTANT_MACROS --enable-mmap=no ZM_SSL_LIB=openssl |make |make install

looks like its working for me

Thanks for the wiki

Cheers

Nigel


Check out overlay zugaina for package www-misc/zoneminder

...Lyall


Hi Lyall

I checked out zugaina for zoneminder and it worked well.

I had to change a couple of things for my system (installed on a fresh/clean gentoo box)

I needed cambozola

wget http://www.charliemouse.com:8080/code/cambozola/cambozola-latest.tar.gz
tar -xzvf cambozola-latest.tar.gz
cp cambozola-0.91/dist/cambozola.jar /var/www/zoneminder

The AXIS camera i have needed more memory

sysctl kernel.shmall=16777216
sysctl kernel.shmmax=268435456

then i put them in

vi /etc/sysctl.conf
sysctl -p
ipcs -l

But the biggest problem was the location of cgi-bin

apache2 was throwing up.

[Wed Apr 25 20:31:06 2012] [error] [client 192.168.1.115] client denied by server configuration: /var/www/localhost/cgi-bin, referer:  http://192.168.1.252/zoneminder/index.php?view=watch&mid=2

It stopped any images in firefox. (zoneminder was recording fine)

I had to move it

cp /var/www/zoneminder/cgi-bin/ /var/www/localhost/cgi-bin/

Now it works fine. (I have no idea about apache config's. Not sure i have done the right thing)

great job on the overlay

I also found that the image size returned from the camera was not the same size as requested. But i could not request the returned size

Cheers

Nigel


I wonder if it has something to do with vhosts

---

Thanks for all the work on this wiki page.

Like Nigel, I had trouble with the cgi-bin. The symptoms for me were a) a 404 in apache logs, couldn't find zms or nph_zms;

[Tue Oct 27 10:38:55.754977 2015] [cgi:error] [pid 29986] [client 192.168.0.9:54882] AH02811: script not found or unable to stat: /var/www/localhost/cgi-bin/nph-zms, .. blah blah
192.168.0.9 - - [27/Oct/2015:10:38:55 -0700] "GET /cgi-bin/nph-zms?source=event&mode=jpeg&event=5&frame=1&scale=50&rate=100&maxfps=30&replay=single&connkey=313914&rand=1445967535 HTTP/1.1" 404 274

and b) apparent missing socket in the zonemaster logs.

ERR [socket_sendto( /var/run/zm/zms-264615s.sock ) failed: No such file or directory]

Reviewing the Apache logs above, it was clear that ScriptAlias wasn't working.

I'll leave aside all the failed investigations :) except to say that this seems an extremely common configuration error, with misleading suggestions on how to fix it all over a lot of forums.

Eventually I read http://httpd.apache.org/docs/2.2/howto/cgi.html, it clearly indicates that ScriptAlias points to a directory, not a file. So the sample in this wiki page is probably incorrect.

I made the following changes in my config. In /etc/apache2/vhosts.d/10_zoneminder.conf:

# ScriptAlias /cgi-bin/zms "/usr/libexec/zoneminder/cgi-bin/zms"
# ScriptAlias /cgi-bin/nph-zms "/usr/libexec/zoneminder/cgi-bin/nph-zms"
ScriptAlias /zm/cgi-bin/ "/usr/libexec/zoneminder/cgi-bin/"

In zm web UI, set

Options -> Paths -> PATH_ZMS = /zm/cgi-bin/zms

After a restart of zm and apache, I am now able to see streamed images.

If this suggestion works for others, perhaps the instructions should be changed.

Best

glenm


This has been what I have been doing for sometime now, so its probably something to add into the instructions instead of the whole troubleshooting section. Does anyone even use zoneminder with other projects on the same box? I've never liked running single box servers under sub folders of the server thus prefer http://cctv.domain/zm/ --> https://cctv.domain/ The ebuild already provides 10_zoneminder.conf - is it best to add this modification into source? FatalFUUU (talk) 10:24, 13 April 2017 (UTC)

---


systemd

Talk status
This discussion is done.

There doesn't seem to be a unit file installed with zoneminder. Is this still relevant?

The ebuilds have unit files, and has done so for a while. /usr/portage/www-misc/zoneminder/files/zoneminder.service FatalFUUU (talk) 10:21, 13 April 2017 (UTC)