Talk:IPv6 Static Addresses using Tokens

From Gentoo Wiki
Jump to:navigation Jump to:search
Note
This is a talk page. Please add newer comments below older ones, and sign your comments using four tildes (~~~~). When adding a new section (at the bottom of the page), please mark it as "open for discussion" by using {{talk|open}} so it will show up in the list of open discussions.

Trouble?

Talk status
This discussion is still ongoing.

This worked well for me on one machine - but another one refuses to assign the ::35 on boot - even with /etc/conf.d/net edited.

At first I thought it was because sysctl shows 'net.ipv6.conf.eno1.accept_ra = 0' (which I had to change to get it to work without a reboot) but even setting that manually in /etc/sysctl.d doesn't make it work - thought it comes up with ra set to 1 after boot.

A restart of the net.eno1 devices sets it back to 0.

I have to do

tank ~ # sysctl -w net.ipv6.conf.eno1.accept_ra=1 net.ipv6.conf.eno1.accept_ra = 1 tank ~ # ip token set ::158 dev eno1 tank ~ # rc-service net.eno1 restart

and then it works - until the next reboot. I can't figure out what is blocking it.

Well, it was working - now rc-service net.eno1 restart kills "accept_ra" and it doesn't work ....

Very annoying. — The preceding unsigned comment was added by Bombcar (talkcontribs) 2021-01-17

Interesting. Did you take a look at your sysctl settings of net.ipv6.conf.default.* ? Maybe accept_ra is set to 0 there and will be set to 0 on the interface on each (device-)restart? It's just a guess. Stefan00 (talk) 11:26, 19 January 2021 (UTC)
Default is 1 as is correct, but eno1 would go to zero. This may be moot as I now have an 10GB card to use but I'm still not sure what was causing it to change. --Bombcar (talk) 20:35, 20 January 2021 (UTC)
Insane! I go to follow this and immediately ra gets turned off for enp4s0f1! "net.ipv6.conf.enp4s0f1.accept_ra = 1" before I do the ip token and rc-service restart, and "net.ipv6.conf.enp4s0f1.accept_ra = 0" after! Posted to the forums here: https://forums.gentoo.org/viewtopic-t-1128565.html --Bombcar (talk) 20:40, 20 January 2021 (UTC)
By editing /etc/dhcpcd.conf and changing slaac from private to hardware I get an IPv6 address based off the MAC address, which is good enough for me (and maybe should be mentioned as an alternative on the main page). --Bombcar (talk) 22:05, 20 January 2021 (UTC)