From Gentoo Wiki
Jump to:navigation Jump to:search
This is a Talk page - please see the documentation about using talk pages. Add newer comments below older ones, sign comments using four tildes (~~~~), and indent successive comments with colons (:). Add new sections at the bottom of the page, under a heading (== ==). Please remember to mark sections as "open for discussion" using {{talk|open}}, so they will show up in the list of open discussions.

Rationale of USEflag template usage

Talk status
This discussion is done.

Hello, I don't understand the use flag table, what good is it for? I think better to describe by functionality what USE is required. --Alon Bar-Lev 12:35, 20 November 2011 (UTC)

At the time of installation you want to check the USE flags. --Astaecker 15:36, 1 December 2011 (UTC)
Not that I really care, but it is obvious... yes, you need to check the flags, however, if you don't automate sync between portage and wiki, sooner than later you get out of sync and produce invalid documentation. sync is also not good as it will create unnecessary revisions. Better use iframe work similar and a webservice that fetches the list... but this may lead to unsynced documentation as well. --Alon Bar-Lev 15:42, 1 December 2011 (UTC)

Setup for Logitech M555b Bluetooth mouse on Gentoo Linux

Talk status
This discussion is done.

The wiki is very accurate. I simply performed the steps as outlined in the wiki and the logitech mouse worked perfectly, recognizing all 5 buttons immediately after the setup steps were performed. This was done with kernel 3.6.6-gentoo, amd64 arch. Is there any place where I can add this information (that my mouse setup was successful), or should I leave it at this discussion page for future discoverability by Google search? — The preceding unsigned comment was added by Ppurka (talkcontribs) 10:10, 17 December 2012‎

I think it's enough to be thankful that the instructions worked for you. --Grknight (talk) 01:13, 8 November 2018 (UTC)

Change Name or Alias for Hostname

Talk status
This discussion is done as of 6 August 2020.

For distinguishing your host on your bluetooth devices, you can provide an alias for your computer hostname.

FILE /var/lib/bluetooth/74\:E5\:43\:FD\:F3\:AB/settings

Note the files /var/lib/bluetooth/MAC_ADDRESS/config and /etc/bluetooth/main.conf also contain hostname variables, but neither seemed to successfully change the hostname to the alias for the remote bluetooth devices.

The change above also required a system reboot for the change to become noticeable on the bluetooth devices. I do not think a simple 'rc-service bluetooth restart' sufficed, and likely a temporary file is persisting within /tmp or /var/tmp someplace!

Thanks for the hint, whoever you are. --Davidbryant (talk) 15:24, 6 August 2020 (UTC)

Timeout for paired devices?

Talk status
This discussion is done as of 6 August 2020.

The timeout seems to be set to a static amount of about 5-10 seconds, regardless of any changes within /etc/bluetooth or custom changes added to /var/lib/bluetooth. I could be skipping another required system reboot, similar to the above 'Change Name or Alias ...' problem. (Odd, I've never had to reboot Linux for any changes -- until using bluetooth under Linux! ;-) --Roger (talk) 00:05, 28 December 2014 (UTC)

Thanks you for the information, Roger. --Davidbryant (talk) 15:26, 6 August 2020 (UTC)

Authors gone?

Talk status
This discussion is done as of December 27, 2014.

Is it normal that authors of this article are not being displayed anymore? Please, attribute. Thank you.

deathwing00 at gentoo dot org (talk) 15:43, 27 December 2014 (UTC)

The article was developed on the Wiki, and the history page lists all authors. Did any of the authors use contents created by you without providing the source? —a3li 15:48, 27 December 2014 (UTC)
Was this not based on the original English version of ? deathwing00 at gentoo dot org (talk) 16:39, 27 December 2014 (UTC)
From a quick comparison, no. —a3li 16:43, 27 December 2014 (UTC)
Makes sense. Is there any information in that old guide worth salvaging and porting to the wiki? deathwing00 at gentoo dot org (talk) 16:48, 27 December 2014 (UTC)
You're the Bluetooth expert, you decide. —a3li 16:56, 27 December 2014 (UTC)
That's a bold statement! :) Deathwing00 (talk) 16:58, 27 December 2014 (UTC)
Be afraid. Be very afraid! ;-) --Roger (talk) 00:06, 28 December 2014 (UTC)

Out of Date Instructions!!

Talk status
This discussion is done as of 6 August 2020.

"simple-agent" no longer exists in current Gentoo (as of 26-Jan-2016) and is replaced by bluetoothctl — The preceding unsigned comment was added by Russelld (talkcontribs) 25 January 2016

simple-agent does exist and it's used by BlueZ 4, which is still in Portage. bluetoothctl is for BlueZ 5.--BT (talk) 23:47, 25 January 2016 (UTC)
oh yes, your right! my bad!
— The preceding unsigned comment was added by Russelld (talkcontribs) 25 January 2016

"rfkill list all" will not show if bluetooth is hardblocked via bios. So this needs to be amended to add that bios needs to be checked to see if Bluetooth is actually switched on, as "rfkill" can't seem to tell when Bluetooth is switched off in bios. — The preceding unsigned comment was added by Russelld (talkcontribs) 25 January 2016

Does rfkill list the Bluetooth controller in this case? --BT (talk) 23:47, 25 January 2016 (UTC)
I have added a note about rfkill and having Bluetooth blocked in the BIOS/UEFI.--BT (talk) 01:10, 26 January 2016 (UTC)
Thanks for adding the note! When Bluetooth is disabled in this bios, rfkill doesn't list bluetooth at all, so its not possible to know if bt is hard blocked or soft blocked - at least with kernel 4.1.15 on a HP Elitebook 8570p. Whereas using a much earlier kernel (3.13.0) did show Bluetooth was hardblocked. After using a BT dongle I found out that kernel (4.1.5) bt services and module were working properly as the bt dongle was seen by the kernel(4.1.5) via rfkill and then I was able to pair to a bt keyboard.
— The preceding unsigned comment was added by Russelld (talkcontribs) 25 January 2016
This discussion is clearly complete. --Davidbryant (talk) 15:29, 6 August 2020 (UTC)

modprobe uhid

Talk status
This discussion is done as of 6 August 2020.

I recently configured a Logitech bluetooth mouse on a Gentoo system, and I found that the uhid module would not load on its own when the device was paired and connected. I had to either compile uhid into the kernel, or make sure the uhid module was loaded before the device was connected in order for the mouse to function in Xorg. Has anyone else had this experience? — The preceding unsigned comment was added by Metafarion (talkcontribs) 03:11, 5 September 2018‎

Apparently not in the past two years. I don't have a bluetooth mouse, but your "problem" makes sense to me. Xorg can't configure a device it can't "see", and it uses the kernel (or a module that was loaded by the kernel) to "see" devices. So you did the right thing by compiling bt support into the kernel. --Davidbryant (talk) 15:35, 6 August 2020 (UTC)