Project:Ruby/Ruby 2.1 deprecation

From Gentoo Wiki
Jump to: navigation, search

Upstream support for Ruby 2.1 has ended on 31st March 2017.[1]

Deprecation plan

  • Get ruby22 package coverage up to the same level as ruby21[2]
  • Stabilize packages with ruby22 support
  • Default Ruby target for new installs to ruby22
  • Package.mask and remove ruby21-only packages

For further information please also check https://bugs.gentoo.org/show_bug.cgi?id=615822