Project:Ruby/Ruby 2.0 deprecation

From Gentoo Wiki
Jump to: navigation, search

Upstream support for Ruby 2.0 has ended on 24th February 2016.[1]

Deprecation plan

  • Get ruby21 package coverage up to the same level as ruby19[2]
  • Stabilize packages with ruby21 support
  • Default Ruby target for new installs to ruby21
  • Package.mask and remove ruby20-only packages

For further information please also check https://bugs.gentoo.org/show_bug.cgi?id=576034