Project:Ruby/Ruby 1.9 deprecation

From Gentoo Wiki
Jump to: navigation, search

Upstream support for Ruby 1.9 has ended on 23rd February 2015.[1]

Deprecation plan

  • Get ruby20 and ruby21 package coverage up to the same level as ruby19[2]
  • Stabilize packages with ruby20 support
  • Default Ruby target for new installs to ruby20
  • Package.mask and remove ruby19-only packages

For further information please also check https://bugs.gentoo.org/show_bug.cgi?id=536852

Packages that have stable versions only available to ruby19

Packages that are currently only available to ruby19

These need to be checked, if ruby20 or later is possible.

dev-java

  • jruby: Move it to ruby/java-overlay; Ping java herd about it, otherwise mask for removal with ruby1.9

dev-libs

net-irc

net-misc

Packages that depend on Ruby 1.9, but don't use the Ruby eclasses

app-mobilephone

  • obexftp-0.23-r2: newer version cannot be stabled so we will mask this package once we mask ruby 1.9 (see https://bugs.gentoo.org/show_bug.cgi?id=547828 ) ; Mask IUSE=ruby or mask package for removal (+ sys-fs/obexfs): Result: Masked USE=ruby for <0.24

sci-libs

sys-apps

Resolved

To be masked

References