Project:Ruby/Ruby 1.8 deprecation

From Gentoo Wiki
Jump to: navigation, search

Ruby 1.8 is currently being deprecated and will be removed from tree (earliest possible: 16th April 2014)

ruby 1.8 final mask (expires April 16th)

# Manuel Rüger <mrueg@gentoo.org> (16 Mar 2014)
# Ruby 1.8 has no longer been supported upstream since July 2013 and
# has known security issues (bug #492282). Ruby packages in general
# are no longer compatible with ruby 1.8. Removal is tracked in bug
# 434064.
#
# This mask also includes all packages still depending in ruby 1.8.
# Removal in 30 days
dev-lang/ruby:1.8
virtual/rubygems:ruby18
virtual/ruby-rdoc:ruby18
virtual/ruby-ssl:ruby18
virtual/ruby-threads:ruby18
app-misc/alexandria
dev-ruby/fastercsv
dev-ruby/oniguruma
dev-ruby/rand
dev-ruby/revolution
dev-ruby/ruby-taglib
dev-ruby/rubytorrent
dev-ruby/sary-ruby
dev-ruby/system_timer
<app-text/migemo-0.40_p2
=dev-ruby/mecab-ruby-0.98-r1

Additional actions:

  • (done) Remove system_timer from dev-ruby/faraday (behind ruby18 USE flag)
  • (done, not needed) Remove fastercsv from dev-ruby/dbf and www-apps/redmine (behind ruby18 USE flag)
  • (done) Remove oniguruma from dev-ruby/textpow and dev-ruby/ultraviolet (behind ruby18 USE flag)
  • profiles/desc/ruby_targets.desc: Add (removed) to ruby18

Masked packages

all other cleaned up.