Project:Perl/mod perl compatibility

From Gentoo Wiki
Jump to: navigation, search

We're documenting the compatibility of various www-apache/mod_perl versions with Apache and Perl versions here. It's a horrible mess that will hopefully be sorted out soon.

If you change anything here, document your source (bug number or who did the testing)!

Apache 2.2 Apache 2.4
Perl 5.20

2.0.8
2.0.10_pre201601
2.0.10_rc1: OK (tested bor, bug #522698

2.0.8: unsupported (dep)
2.0.10_pre201601: OK (tested mjo)
2.0.10_rc1: ?

Perl 5.22

2.0.8: crashes (bug #554794)
2.0.10_pre201601
2.0.10_rc1: OK (bug #576348)

2.0.8: unsupported (dep)
2.0.10_pre201601: OK (tested blackbird)
2.0.10_rc1: OK (bug #576348)

Perl 5.24

2.0.8: ?
2.0.10_pre201601: ?
2.0.10_rc1: ?

2.0.8: unsupported (dep)
2.0.8-r3: ?
2.0.10_pre201601: ?
2.0.10_rc1: OK (tested dilfridge)