Project:GNOME/libsoup:3 transition

From Gentoo Wiki
Jump to:navigation Jump to:search

Reverse dependencies of net-libs/libsoup

Supports libsoup:3.0 only

  • app-backup/deja-dup >= 43.1
  • app-text/gtranslator >= 42.0
  • app-text/libgepub >= 0.7.0
  • dev-libs/libgweather:0
  • dev-util/gnome-builder >= 43.0
  • gnome-base/gvfs >= 1.50
  • gnome-extra/evolution-data-server >= 3.46.0
  • gnome-extra/evolution-ews >= 3.46.0
  • gnome-extra/gnome-boxes >= 43.0
  • gnome-extra/gnome-calculator >= 43.0
  • gnome-extra/gnome-calendar >= 43.0
  • mail-client/evolution >= 3.46.0
  • mail-client/geary >= 43.0
  • net-libs/gnome-online-accounts >= 3.46.0
  • net-libs/gssdp:1.6
  • net-libs/gupnp:1.6
  • net-libs/rest:1.0
  • net-libs/uhttpmock:1.0
  • net-libs/webkit-gtk:4.1
  • net-libs/webkit-gtk:5
  • net-libs/phodav:3.0
  • net-misc/gupnp-tools >= 0.12.0
  • net-misc/rygel >= 0.42
  • sci-geosciences/gnome-maps >= 43.0

Optionally either libsoup:2.4 or libsoup:3.0

  • app-misc/tracker:3
  • dev-libs/libgweather:4
  • gnome-base/gnome-shell
  • gnome-extra/gnome-software
  • media-libs/grilo
  • sci-geosciences/geocode-glib >= 3.26.3
  • sys-libs/libosinfo
  • www-client/epiphany

Automagically chooses libsoup version

  • media-plugins/grilo-plugins (based on what the system's media-libs/grilo supports)
  • media-plugins/gst-plugins-soup (chooses at runtime)
  • net-irc/polari >= 41.0 (chooses at runtime)
  • net-misc/spice-gtk >= 0.41 (chooses at build-time, see bug #876802
  • sys-apps/osinfo-db-tools

Supports libsoup:2.4 only

... but supports libsoup:3.0 in a released version

  • app-backup/deja-dup < 43.1 (switched to libsoup:3.0-only in this upstream commit)
  • app-text/gtranslator < 42.0 (switched to libsoup:3.0-only in this upstream commit)
  • app-text/libgepub < 0.7.0
  • dev-util/gnome-builder < 43.0
  • gnome-base/gvfs < 1.50
  • gnome-extra/evolution-data-server < 3.46.0
  • gnome-extra/evolution-ews < 3.46.0
  • gnome-extra/gnome-boxes < 43.0
  • gnome-extra/gnome-calculator < 43.0
  • gnome-extra/gnome-calendar < 43.0
  • mail-client/evolution < 3.46.0
  • mail-client/geary < 43.0
  • net-libs/gnome-online-accounts < 3.46.0
  • net-libs/gssdp:0
  • net-libs/gupnp:0
  • net-libs/rest:0.7
  • net-libs/uhttpmock:0
  • net-libs/webkit-gtk:4
  • net-libs/phodav:2.0
  • net-misc/gupnp-tools < 0.12.0
  • net-misc/rygel < 0.42
  • net-misc/spice-gtk < 0.41
  • sci-geosciences/geocode-glib < 3.26.3
  • sci-geosciences/gnome-maps < 43.0

... but supports libsoup:3.0 upstream

... and does not support libsoup:3.0 upstream

... because the libsoup dependency was removed

  • dev-libs/appstream-glib < 0.8.0 (dependency removed in this upstream commit)
  • games-util/lutris (depends on webkit-gtk:4.0, but not libsoup:2.4, see bug #876807)
  • sys-apps/flatpak (made libcurl the preferred option in >= 1.13.3, see bug #876804)
  • sys-apps/fwupd (see bug #876800)

Unknown

  • app-office/homebank (code is in bazaar in https://code.launchpad.net/homebank)
  • dev-libs/libtimezonemap (unclear to me where the 0.4.6 release is from)
  • gnome-extra/cinnamon (I don't understand this package. It doesn't directly depend on libsoup, but its Debian control file depends on gir1.2-soup-2.4)
  • media-gfx/colorhug-client (status of package unclear. upstream git repo is archived)
  • net-misc/icaclient (binary package)