Project:Ruby/Pending Bumps

From Gentoo Wiki
Jump to: navigation, search

A irregularly updated list of pending ruby version bumps for the main tree can be found here: outdated-gems. Not all packages on that list are straightforward to bump. This list collects notes on packages that have issues and need more work to be bumped. Feel free to help tackle any of these issues!

dev-ruby

adhearsion 2.3.5

  • Many new unpackaged dependencies: adhearsion-loquacious, celluloidtimers, countdownlatch, deep_merge, future-resource, girl_friday, has-guarded-handlers, logging, punchblock → (blather, niceogiri, ruby_ami, ruby_fs, state_machine, virtus), ruby_speech

ammeter 1.0.0

  • Tests no longer run and seem to require database connection out of the box.

blankslate 3.1.3

  • Fails tests

coolio-1.2.4

  • Fails tests intermittently.

dalli 2.7.2

  • Tests crash ruby 1.9 and ruby 2.0.

dep_selector 1.0.3

  • Has new dependency dep-selector-libgecode

em-http-request 1.1.0

  • depends on mongrel 1.2.0-pre2 which we won't add because it is a pre-release version.
  • now also depends on beta version of http_parser.rb

eventmachine 1.0.4

  • Fails tests.

gettext_i18n_rails 1.0.5

  • Fails tests

github_api 0.12.2

  • Fails webmock tests. It needs 1.17.x according to the upstream Gemfile, but we only have 1.19 so it may be a compatibility issue there.

gherkin 2.12.2

hike 2.1.3

  • Not tagged upstream and gem does not contain tests.

launchy 2.4.2

  • Fails tests.

mechanize 2.7.3

  • Fails tests.

mixlib-log 1.6.0

  • Not tagged upstream.

moneta 0.7.15

  • New home at https://github.com/minda/moneta
  • Many non-optional tests for things we have not packaged.
  • Pulling in all things we *do* package will add a ton of dependencies.
  • Tests depend on rspec-retry which is not packaged yet.

mongo 1.6.4

  • See bson

mongoid

  • Version 2.4.11 is just restricting the dependency to bson 1.6.2 as the later versions have changed API badly (they should be called 1.7); since we're not bumping bson, this won't be a problem for the moment;
  • Version 3.0 is Ruby 1.9 -only (and JRuby in 1.9 mode) and is requiring more work.

multi_xml 0.5.5

  • Fails tests without dev-ruby/ox, but also fails when it is installed, in a different way.

open4 1.3.4

  • Has otherwise unspecified "test_case" requirement and it's not clear which gem provides this.

rgen 0.7.0

right_http_connection 1.4.0

  • Not tagged upstream.

ruby-beautify 0.94.1

  • Fails test because the script does not actually output any beautified code.

ruby-prof 0.15.2

  • Not tagged upstream.

ruby-progressbar 1.7.1

  • The use of rspectacular requires bundler, which leads to a lot of dependency mismatches due to overly strict requirements. Even when these are fixed rspectacular causes issues.

sanitize 3.0.0

  • New dependency on nokogumbo

seed_fu 2.3.1

  • Specs fails with rails 4.0 due to use of attr_protected without including the gem for it.

shoulda-context 1.2.1

  • Test suite now requires Appraisal (or at least a specific test bundle gemfile).

sprockets-rails 2.1.4

  • Fails on new manifest creation tests. Upstream travis tests pass.

stomp 1.3.3

  • Fails tests.

www-apps