User:Ris/etc/wiki svg issue 2022

From Gentoo Wiki
Jump to:navigation Jump to:search
Note
This seems solved! See bug #888471. Thanks Matthew Marchese (maffblaster)  !!

There seems to be an issue with displaying SVG images on the wiki. It appears that SVG images uploaded to the wiki result in an error rather than displaying the image. SVGs that has been on the wiki for a while still work, but if they somehow get a cache invalidated (such as by clicking "more>refresh"), a similar issue seems to occur for them - so on the face of it, the issue doesn't seem to be with the uploaded files.

I've made (Inkscape) and uploaded the simplest of images to test. The error message displayed is:

Error creating thumbnail: Error reading SVG:Error domain 1 code 1 on line 1 column 1 of file:///tmp/svg_016b15b415a8dbc67c1217db/Testimage.svg: internal error: Unfinished entity outside the DTD

Link to image that has been on the wiki for a while and previously worked fine, but threw an error after clicking "more>refresh" in the wiki menu.

An svg image that worked previously can be included in a page if the size is the same as inclusions on other pages. If the size is changes substantially however, it throws the error:

SVG graphic of Larry the cow
Larry in his younger years wearing designer suede hoofs.
SVG graphic of Larry the cow
Larry in his younger years wearing designer suede hoofs.

The error was first encountered when trying to insert an SVG image that has been working for a while on the wiki into an article.